Security Advisories

CVE-2021-33603: Denial-of-Service (DoS) Vulnerability

Description

Denial-of-service of the antivirus engine when scanning a fuzzed file.

STATUS: Fixed

RISK LEVEL: Medium

FIX: No user action is required. The required fix has been published through automatic update channel with Capricorn update 2021-09-29_03.

Affected Products

Corporate Products:

  • All F-Secure endpoint protection products on Windows and Mac
  • F-Secure Linux Security (32-bit)
  • F-Secure Linux Security 64
  • F-Secure Atlant
  • F-Secure Internet Gatekeeper
  • F-Secure Cloud Protection for Salesforce
  • F-Secure Elements for Microsoft 365

Platforms

  • All supported platforms for the affected products

More Information

A denial-of-service (DoS) vulnerability was discovered in F-Secure Atlant whereby the AVPACK module component used in certain F-Secure products can crash while scanning a fuzzed files. The exploit can be triggered remotely by an attacker. A successful attack will result in denial-of-service (DoS) of the antivirus engine.

This issue was reported to F-Secure through the Vulnerability Reward Program. No known exploit or attack has been seen in the wild.

Credits

F-Secure Corporation would like to thank Antti Levomäki and Christian Jalio from Forcepoint for bringing this issue to our attention.

Date Issued: 2021-10-08