Security Advisories

CVE-2021-33572: Denial-of-Service (DoS) Vulnerability

Description

Crash while scanning fuzzed files can cause Denial-of-Service of antivirus engine.

STATUS: RESOLVED

RISK LEVEL: LOW

FIX: No user action is required. The required fix has been published through automatic update channel with Capricorn update 2021-04-29_07.

Affected Products

Corporate Products:

  • All F-Secure endpoint protection products on Windows, Mac and Linux
  • F-Secure Security Cloud
  • F-Secure Elements for Microsoft 365
  • F-Secure Cloud Protection for Salesforce

Platforms

  • All supported platforms for the affected products

More Information

A Denial-of-Service (DoS) vulnerability was discovered in F-Secure Linux Security whereby the FSAVD component used in certain F-Secure products can crash while scanning larger packages/fuzzed files. The exploit can be triggered remotely by an attacker. A successful attack will result in Denial-of-Service (DoS) of the antivirus engine.

This issue was reported to F-Secure through the Vulnerability Reward Program. No known exploit or attack has been seen in the wild.

Credits

F-Secure Corporation would like to thank Antti Levomäki and Christian Jalio from Forcepoint for bringing this issue to our attention. 

Advisory changes

Date Changes
3rd June 2021 First advisory published.
9th June 2021 Added F-Secure Security Cloud, F-Secure Elements for Microsoft 365, and F-Secure Cloud Protection for Salesforce to list of affected products.

Date Issued: 2021-06-03
Date Last Updated: 2021-06-09