1. Skip to navigation
  2. Skip to content
  3. Skip to secondary-content




F-Secure Products ZIP and RAR Archives Security Bypass

Report ID: SA200901971
Source: Secunia
Date of Discovery: 06.05.2009
Criticality: Negligible
Affects:
F-Secure Anti-Virus 2006
F-Secure Anti-Virus 2007
F-Secure Anti-Virus 2008
F-Secure Anti-Virus 2009
F-Secure Anti-Virus for Citrix Servers 7.x
F-Secure Anti-Virus for Linux 4.x
F-Secure Anti-Virus for Microsoft Exchange 6.x
F-Secure Anti-Virus for Microsoft Exchange 7.x
F-Secure Anti-Virus for MIMEsweeper 5.x
F-Secure Anti-Virus for Windows Servers 7.x
F-Secure Anti-Virus for Windows Servers 8.x
F-Secure Anti-Virus for Workstations 7.x
F-Secure Anti-Virus for Workstations 8.x
F-Secure Anti-Virus Linux Client Security 5.x
F-Secure Anti-Virus Linux Server Security 5.x
F-Secure Client Security 7.x
F-Secure Client Security 8.x
F-Secure Home Server Security 2009
F-Secure Internet Gatekeeper 6.x
F-Secure Internet Gatekeeper for Linux 2.x
F-Secure Internet Gatekeeper for Linux 3.x
F-Secure Internet Security 2008
F-Secure Internet Security 2009
F-Secure Linux Security 7.x

Compromise From: From remote
Compromise Type: Security bypass

Summary

A weakness has been reported in various F-Secure products, which can be exploited by malware to bypass the scanning functionality.

Detailed Description

A weakness has been reported in various F-Secure products, which can be exploited by malware to bypass the scanning functionality.

The weakness is caused due to an error in the handling of ZIP and RAR files and can be exploited to bypass the anti-virus scanning functionality via a specially crafted ZIP or RAR file.

The weakness affects the following products:
* F-Secure Anti-Virus for Microsoft Exchange 7.10 and earlier
* F-Secure Internet Gatekeeper for Windows 6.61 and earlier
* F-Secure Internet Gatekeeper for Linux 2.16 and earlier
* F-Secure Internet Gatekeeper for Linux Japanese 3.01 and earlier
* Solutions based on F-Secure Protection Service for Business - E-mail and Server security version 8.00 and earlier
* F-Secure Internet Security 2009 and earlier
* F-Secure Anti-Virus 2009 and earlier
* F-Secure Client Security 8.0 and earlier
* F-Secure Anti-Virus for Workstations 8.0 and earlier
* F-Secure Linux Security 7.01 and earlier
* F-Secure Anti-Virus Linux Client Security 5.54 and earlier
* Solutions based on F-Secure Protection Service for Consumers version 8.00 and earlier
* Solutions based on F-Secure Protection Service for Business - Workstation security version 8.00 and earlier
* F-Secure Home Server Security 2009
* F-Secure Anti-Virus for Windows Servers 8.00 and earlier
* F-Secure Anti-Virus for Citrix Servers 7.00 and earlier
* F-Secure Linux Security 7.02 and earlier
* F-Secure Anti-Virus Linux Server Security 5.54 and earlier
* F-Secure Anti-Virus for Linux Servers 4.65
* F-Secure Anti-Virus for MIMEsweeper 5.61 and earlier

Solution

Apply patches. Please see the vendor's advisory for details.
www.f-secure.com/en_EMEA/support/security-advisory/fsc-2009-1.html

Original Reference

-