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INTRODUCTION

This guide describes how to get started with F-Secure Client
Security. Installation instructions are included for the following:

m F-Secure Client Security
m F-Secure Policy Manager

For detailed installation, use and product instructions, see the
applicable F-Secure product manuals included on the

F-Secure CD. You can access them from the CD menu by clicking
Manuals, or you can go to our website for the most recent
manuals in PDF format. The direct link to the manuals is
http://www.f-secure.com/small_businesses/
support_and_services/manuals.html.

For printing any manuals from either the CD or the website, you
must have Adobe Acrobat 4% or a later version installed. Adobe
Acrobat ® is available on your CD.


http://www.f-secure.com/small_businesses/support_and_services/manuals.html
http://www.f-secure.com/small_businesses/support_and_services/manuals.html

2

2.1

| 4

F-SECURE CLIENT SECURITY

This chapter describes how to install F-Secure Client Security on
corporate computers. The following are explained:

m  System Requirements

m  Remote and local installation options for corporate
computers

For more detailed information, see the F-Secure Client

== Security Administrator’s guide and online help. The guide
is available on the CD, and the online help is installed with
the product.

_You can open the online help by pressing F1 or clicking
-/ Help in any window or dialog in F-Secure Client Security.

System Requirements

Your computer must meet these requirements to run F-Secure
Client Security:

Processor: Intel Pentium Il 600Mhz or higher (1Ghz or
higher recommended)

Operating Windows 2000 Professional (with Service Pack

system: 4 or higher)

Windows XP Professional or Home Edition
(SP 2 required for full functionality)

Memory: 256 MB of RAM (512 MB recommended)
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Free hard disk | 150 MB (200 MB recommended)
space:

Other: Internet connection recommended

2.2 Installation Options

F-Secure Client Security can be installed in the following ways:

m Stand-Alone Installation
m  Remote Installation with F-Secure Policy Manager
m Local Installation and F-Secure Policy Manager

For detailed instructions, see the F-Secure Client Security
=~ Administrator’'s Guide available on the CD and on our
website at http://www.f-secure.com/small_businesses/
support_and_services/manuals.html.

2.2.1 Stand-Alone Installation

F-Secure Client Security can be installed individually on each
workstation. This method is recommended for small networks with
2-5 workstations.


http://www.f-secure.com/small_businesses/support_and_services/manuals.html
http://www.f-secure.com/small_businesses/support_and_services/manuals.html

Step 1 - Uninstall any other antivirus programs on your
computer

1. Uninstall any other antivirus programs on your computer as
follows:

a. Click Start-=>Settings—>Control Panel>Add or Remove
Programs.

b. Click the programs you want to remove.
c. Click Remove (or Change/Remove).

2. The programs may have several related components. Repeat
steps b and c to uninstall all. (Related components have the
same product name.)

3. Restart your computer.

For uninstalling other antivirus programs, refer to their user
documentation, or refer to your operating system user
documentation.
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Step 2 - Install F-Secure Client Security:

1.

Insert the F-Secure Workstation & Server Security CD in the
CD-ROM drive.

Select the installation language.
Click F-Secure Client Security listed under Anti-Virus.

Read the Welcome screen and select the language in which
you want to install F-Secure Client Security. Click Next.

Read the License Agreement text carefully, select | accept
this agreement and click Next.

= If you select | reject this agreement, you cannot
@ install the product.

Enter the keycode you received with your product, and click
Next.

Select the type of installation:

m If you select Typical, F-Secure Client Security is installed
in the default directory, C:\Program Files\ F-Secure, with
Virus & Spy Protection, Automatic Update Agent, Internet
Shield, E-mail Scanning and Web Traffic Scanning
enabled.

m If you select Custom, you can choose what to install and
where.



8. Click Next.

9. If you selected Typical installation, go to step 11. If you
selected Custom installation, select the components to install
and then click Next:

Virus & Spy Protection to enable the real-time virus
protection and scanning for spyware

Internet Shield to install the integrated firewall

E-mail Scanning to have all your inbound and outbound
e-mails scanned for viruses

Web Traffic Scanning to protect your computer against
viruses in HTTP traffic.

System Control to protect your computer against
unknown malware and unwanted system changes.

SNMP Support to enable the protection of your computer
to be managed using the Simple Network Management
Protocol (SNMP).

Cisco NAC Support to enable the integration of Cisco
Network Admission Control (NAC) with the product.

10. Choose the folder where you want to install F-Secure Client
Security and click Next.

We recommend choosing the default location,

-/ C:\Program Files\F-Secure.

11. Select Locally managed stand-alone installation and click
Next.

12. Verify the list of components, and click Start to start the
installation. When the installation is finished, click Next to
continue.
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13. Restart your computer, if you are prompted to do that, by
selecting Restart now and click Finish.

14. After restarting the computer, if prompted, update the virus
definition databases as soon as you are connected to the
network.

2.2.2 Remote Installation with F-Secure Policy
Manager

Remote installation with F-Secure Policy Manager is
recommended for networks with more than 5 workstations.

If you are not familiar with F-Secure Policy Manager, see the
F-Secure Policy Manager Administrator’'s Guide available on the
CD.

=  F-Secure Policy Manager has two user interfaces:

“’  Advanced Mode and Anti-Virus Mode. You should use
Anti-Virus Mode with F-Secure Client Security. After you
have installed F-Secure Policy Manager, open the View
menu and select Anti-Virus Mode.



Step 1 - Uninstall any other antivirus programs on the target
computer

1. Uninstall any other antivirus programs on the target computer
as follows:

a. Click Start-=>Settings—>Control Panel>Add or Remove
Programs.

b. Click the programs you want to remove.
c. Click Remove (or Change/Remove).

2. The programs may have several related components. Repeat
steps b and c to uninstall all. (Related components have the
same product name.)

3. Restart your computer.

For uninstalling other antivirus programs, refer to their user
documentation, or refer to your operating system user
documentation.

Step 2 - Install F-Secure Policy Manager
1. Install F-Secure Policy Manager.

For installation instructions, see chapter Installing
== F-Secure Policy Manager in F-Secure Client Security
Administrator’s Guide.

2. Create the policy domain structure.

For instructions, see chapter Creating the Domain
== Structure in F-Secure Client Security Administrator’s
Guide.

Step 3 - Install F-Secure Client Security Remotely

The following steps are a general guideline for remote installation:

1. Use ‘Autodiscover Windows Hosts’ operation to install
F-Secure Client Security to the workstations. F-Secure Policy

10
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Manager Console will use a Remote Installation Wizard to
configure the F-Secure Client Security installation.

For instructions, see chapter Adding Hosts in
=" F-Secure Client Security Administrator’s Guide.

2. Add new workstations to a suitable policy domain when the
installation is complete.

3. Configure the F-Secure Client Security settings for the
workstations. The domain level settings are shared by all

workstations in the policy domain.

For instructions, see chapters Configuring Virus &
== Spy Protection and Configuring Internet Shield in
F-Secure Client Security Administrator’s Guide.

4. Distribute the policies. The managed workstations will receive
the updated policy the next time they connect to the server.

2.2.3 Local Installation and F-Secure Policy Manager

Local installation is recommended if you need to install F-Secure
Client Security locally on a workstation that is otherwise centrally
managed by F-Secure Policy Manager. You must have F-Secure
Policy Manager already installed before you can continue with the
installation.
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Step 1 - Uninstall any other antivirus programs on your
computer

1. Uninstall any other antivirus programs on your computer as
follows:

a. Click Start-=>Settings—>Control Panel>Add or Remove
Programs.

b. Click the programs you want to remove.
c. Click Remove (or Change/Remove).

2. The programs may have several related components. Repeat
steps b and c to uninstall all. (Related components have the
same product name.)

3. Restart your computer.

For uninstalling other antivirus programs, refer to their user
documentation, or refer to your operating system user
documentation.
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Step 2 - Install F-Secure Client Security

1.

Insert the F-Secure Workstation & Server Security CD in the
CD-ROM drive.

Select the installation language.
Click F-Secure Client Security listed under Anti-Virus.

Read the Welcome screen and select the language in which
you want to install F-Secure Client Security. Click Next.

Read the License Agreement text carefully, select | accept
this agreement and click Next.

i If you select | reject this agreement, you cannot
<Y install the product.

Enter the keycode you received with your product, and click
Next.

Select the type of installation:

m If you select Typical, F-Secure Client Security is installed
in the default directory, C:\Program Files\ F-Secure, with
Virus & Spy Protection, Automatic Update Agent, Internet
Shield, E-mail Scanning and Web Traffic Scanning
enabled.

m If you select Custom, you can choose what to install and
where.

Click Next.
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11.

12.

13.

If you selected Typical installation, go to step 11. If you
selected Custom installation, select the components to install
and then click Next:

m Virus & Spy Protection to enable the real-time virus
protection and scanning for spyware

m Internet Shield to install the integrated firewall

m  E-mail Scanning to have all your inbound and outbound
e-mails scanned for viruses

m  Web Traffic Scanning to protect your computer against
viruses in HTTP traffic.

m System Control to protect your computer against
unknown malware and unwanted system changes.

m  SNMP Support to enable the protection of your computer
to be managed using the Simple Network Management
Protocol (SNMP).

m Cisco NAC Support to enable the integration of Cisco
Network Admission Control (NAC) with the product.

Choose the folder where you want to install F-Secure Client
Security and click Next.

i We recommend choosing the default location,
Y C:\Program Files\F-Secure.

Select Central management with F-Secure Policy
Manager, and click Next.

Enter the path to the public Management Key that you created
during the F-Secure Policy Manager Console setup. Click the
Browse button to search for the key.

Enter the http address of the F-Secure Policy Manager Server.
Click Next.

14
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14. Verify the list of components, and click Start to start the
installation. When the installation is finished, click Next to
continue.

15. Restart your computer, if you are prompted to do that, by
selecting Restart now and click Finish.

Step 3 - Configure the product using F-Secure Policy
Manager Console:

1. Add a new workstation to a suitable policy domain using the
‘Import Autoregistered Hosts’ operation.

2. Configure the F-Secure Client Security settings for the
workstation. The domain level settings are shared by all
workstations in the policy domain.

3. Distribute the policies. The managed workstation will receive
the updated policy the next time it connects to the server.
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3 F-SECURE PoLicy MANAGER

This chapter is a quick reference for installing F-Secure Policy
Manager from the F-Secure Workstation & Server Security CD.
The following are explained:

System requirements
User interface modes

Installation steps for installing all F-Secure Policy Manager
components on a single computer.

Remote deployment of F-Secure products to corporate
computers.

For more detailed information and alternate set-ups, see
the F-Secure Policy Manager Administrator's Guide.

For information on installing F-Secure Policy Manager on
Linux, see chapter F-Secure Policy Manager on Linux in
F-Secure Policy Manager Administrator’s Guide.

For more information on F-Secure Policy Manager Web
Reporting, see chapter Web Reporting in F-Secure Policy
Manager Administrator’s Guide.

For information on F-Secure Policy Manager Reporting
Option, see the F-Secure Policy Manager Reporting Option
Administrator’s Guide.

For more information on F-Secure Client Security, see the
F-Secure Client Security Administrator’s guide.

These guides are available on your F-Secure product CD,
or from http://www.f-secure.com/small_businesses/
support_and_services/manuals.html.



http://www.f-secure.com/small_businesses/support_and_services/manuals.html
http://www.f-secure.com/small_businesses/support_and_services/manuals.html
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3.1 System Requirements

F-Secure Policy Manager Server

Operating Microsoft Windows 2000 Server SP 3 or higher
System: Microsoft Windows 2000 Advanced Server SP 3 or
higher
Windows Server 2003, Standard Edition or Web
Edition

Windows 2003 Small Business Server

Processor: Intel Pentium 111 450 MHz processor or faster.
Managing more than 5000 hosts or using Web
Reporting requires Intel Pentium 11l 1 GHz level
processor or faster.

Memory: 256 MB of RAM. When Web Reporting is enabled,
512 MB RAM

Disk space: Disk space: 200 MB of free hard disk space; 500
MB or more is recommended. The disk space
requirements depend on the size of the installation.
In addition, allocate about 1 MB per host for alerts
and policies. The actual disk space consumption
per host depends on how the policies are used and
how many installation packages are stored.

~ For information on installing F-Secure Policy Manager on
-/ Linux, see chapter F-Secure Policy Manager on Linux in
F-Secure Policy Manager Administrator’s Guide.
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F-Secure Policy Manager Console

Operating Microsoft Windows 2000 Professional (SP3 or
system: higher);
Windows 2000 Server (SP3 or higher)
Windows 2000 Advanced Server (SP3 or
higher)
Windows XP Professional (SP2 or higher);
Windows Server 2003, Standard Edition or Web
Edition.
Windows 2003 Small Business Server.

Processor: Intel Pentium 111 450 MHz processor or faster.
Managing more than 5000 hosts requires Pentium
11l 750 MHz processor or faster

Memory: 256 MB of RAM. Managing more than 5000 hosts
requires 512MB of memory

Disk space: 100 MB of free hard disk space

Display Minimum 256-color display with resolution of

resolution: 1024x768, (32-bit color with 1280x960 or higher
resolution recommended).

Other: Ethernet network interface or equivalent. 10 Mbit
network between console and server is
recommended.

Managing more than 5000 hosts requires 100Mbit
connection between console and server.

Larger amounts of memory and free disk space will improve
Y performance considerably.
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3.2

3.3

User Interfaces

F-Secure Policy Manager has two user interfaces:

= Anti-Virus Mode
m  Advanced Mode

Use the Anti-Virus Mode user interface for managing F-Secure
Client Security, and Advanced Mode for managing all other
F-Secure products.You can select the user interface from the
View menu in F-Secure Policy Manager Console.

Installation Instructions

You can install F-Secure Policy Manager components, F-Secure
Policy Manager Server and F-Secure Policy Manager Console, on
the same computer, or on separate dedicated computers. In these
instructions, F-Secure Policy Manager Server and F-Secure
Policy Manager Console will be installed on the same computer.

For instructions on installing F-Secure Policy Manager
= Server and F-Secure Policy Manager Console on separate
computers, see the F-Secure Policy Manager
Administrator’s Guide.

To install F-Secure Policy Manager Server, you need physical
access to the server machine.
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To install F-Secure Policy Manager:

1.
2.

Insert the F-Secure CD in your CD-ROM drive.

From the Management menu, select F-Secure Policy
Manager to start the setup.

Read the welcome screen, and select the installation
language. Click Next.

Read the License Agreement text. Select | accept this
agreement, and click Next.

Select the type of installation:
m  Typical - Setup installs the product with default options:

m F-Secure Policy Manager Server, F-Secure Policy
Manager Console, F-Secure Policy Manager Update
Server & Agent are installed on the same computer.

m The default ports are used for F-Secure Policy
Manager Server modules.

m  Only the F-Secure Policy Manager Console installed
on the same computer is allowed access to F-Secure
Policy Manager Server.

m  Access to Web Reports is allowed also from other
computers.

m Custom - This is the default (recommended) option that
lets you specify, for example, the installation directory and
the ports for F-Secure Policy Manager Server modules.

m Reinstall - This option reinstalls all existing components
and restores the missing settings. This dialog is only
displayed if there is a previous F-Secure Policy Manager
installation on the computer.
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6.

If there is no previous F-Secure Policy Manager installation on
the computer, select the components to be installed:

m F-Secure Policy Manager Console
m F-Secure Policy Manager Server

m F-Secure Policy Manager Update Server & Agent
(automates virus and spyware definition database
updates)

m F-Secure Installation Packages

Select this option if you want to upload/install new remote
installation packages from the CD (recommended).

Accept the default installation directory (recommended). If you
want to install the components in another directory, click
Browse and enter your desired directory.

If Setup does not detect a previous F-Secure Policy Manager
installation, you are requested to confirm if a previous
installation of F-Secure Policy Manager exists.

m If Yes, select | have existing an F-Secure Policy
Manager installation. Enter the communication directory
path of the installed F-Secure Policy Manager.

m If No, select | do not have an existing F-Secure Policy
Manager.
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9. Select whether you want to keep the existing settings or
change them.

i This dialog is displayed only if a previous installation
</ of F-Secure Policy Manager Server was detected on
the computer.

m By default the setup keeps the existing settings. Select this
option if you have manually updated the F-Secure Policy
Manager Server configuration file (HTTPD.conf). This
option automatically keeps the existing administration, host
and web reporting ports.

m If you want to change the ports from the previous
installation, select the Change settings option. This option
overwrites the HTTPD.conf file, and restores the settings
to defaults.

10. Select the F-Secure Policy Manager Server modules to
enable:

m  Host module is used for communication with the hosts.
The default port is 80.

m  Administration module is used for communication with
F-Secure Policy Manager Console. The default HTTP port
is 8080.

= If you want to change the default port for
-/ communication, you will also need to change the
HTTP Port Number setting in F-Secure Policy
Manager Console.

By default the access to the Administration module is
restricted to the local machine. This is the most secure
way to use the product.
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When using a connection over a network, please consider
securing the communication with F-Secure SSH or
F-Secure VPN+.

For environments requiring maximum security, see

= section Installing F-Secure Policy Manager in High
Security Environments in F-Secure Policy Manager
Administrator’s Guide

m  Web Reporting module is used for communication with
F-Secure Policy Manager Web Reporting. Web Reporting
uses a local socket connection to the Admin module to
fetch server data. The default port is 8081.

By default access to Web Reports is allowed also from
other computers. If you want to allow access only from this
computer, select Restrict access to the local machine.

11. Specify the F-Secure Policy Manager Server address, and
Administration port number. Click Next to continue.

i Depending on the installation method, the server
Y address and port number are not always required.

12. Select to add product installation package(s) from the list of
available packages (if you selected F-Secure Installation
Packages in step 6 ).

13. Setup displays the components that will be installed. Click
Start to start the installation.

14. After setup has copied the files to your computer, click Finish
to complete the setup.

m To determine if your server-side installation was
successful, open a web browser in the machine where
F-Secure Policy Manager Server was installed, enter
http://localhost and press Enter. If the server installation



was successful, a page will be displayed stating that
F-Secure Policy Manager Server installation was
successful.

m  Run F-Secure Policy Manager Console Setup Wizard. If it
does not start automatically, go to the Windows Start
menu, select Programs=>F-Secure Policy Manager
Console=>F-Secure Policy Manager Console.

Continue to the “F-Secure Policy Manager Console Setup
Wizard” section.

F-Secure Policy Manager Console Setup Wizard

1. Read the setup wizard overview that summarizes the
installation process.

2. Select Administrator mode to enable all administrator
features.

3. Enter the path where the administrator’s public key and private
key files will be stored. By default, key files are stored in the
F-Secure Policy Manager Console installation directory.

i If the key-pair does not exist already, it will be created
Y later in the setup process.

4. Move your mouse cursor around in the window to initialize the
random seed used by the management key-pair generator.
When the progress indicator has reached 100%, the
Passphrase dialog box opens automatically.

5. Enter a passphrase for F-Secure Policy Manager Console
(this will be needed for logging into F-Secure Policy Manager
Console).

6. Click Finish to complete the setup process. Your key-pair will
now be created.

7. When the F-Secure Policy Manager Console user interface
opens, at the bottom of the screen you see a progress bar

24
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indicating the verification of the installation package. The
verification may take a few minutes.

i If the verification does not start, go to Tools=>
Y Installation Packages and check to see that the
installation package is listed.

8. Open Tools=>Installation Packages. Check that the status of
the packet on the list is OK (if the status is not OK, please
reinstall). When the status is OK, setup is complete.

Remote Deployment of Other F-Secure Products

F-Secure Policy Manager can install software to new hosts that
are not yet under centralized management. These hosts can be
browsed from Windows NT domains using the Autodiscover
Windows Hosts feature. The software is then push installed to the
managed hosts.

F-Secure Policy Manager offers other methods of installing and
updating managed applications. Shortcuts to all the
installation-related features are gathered in the Properties pane
under the Installation tab. Please see the F-Secure Policy
Manager Administrator’s Guide for details.

=  For Windows 98/ME hosts, you must enable remote
@ installation for this installation to work. See the F-Secure
Policy Manager Administrator’s Guide for more
information.

The following steps are for both the Advanced Mode and
Anti-Virus Mode user interface:

1. In F-Secure Policy Manager, select the policy domain
containing the hosts to which you will install.

2. Open the Edit menu and select Autodiscover Windows

Hosts (alternatively, click the -%"T-'l button). From the NT
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Domains list that opens, select one of the domains and click
Refresh. Select the hosts to be imported and click Install.

3. After you have selected the target hosts, select the installation
package.

4. Select the products to install. You can choose to force
reinstallation if applications with the same version number
already exist.

5. Choose to accept the default policy, or specify which host or
domain policy should be used as an anonymous policy.

6. Choose the user account and password used to perform the
push installation.

7. Review the installation summary. To start the Remote
Installation Wizard, click Start.

8. F-Secure Policy Manager installs the selected products on the
hosts.

9. When the Status line displays finished, the process is
complete. You can select in which domain the new hosts
should be placed using the import settings. Click Finish.

10. When the installation is finished;

m In Advanced Mode, open the F-Secure Policy Manager
Console Properties pane to view the list of products that
were installed. To see this list, you must first select the top
domain in the Policy Domain pane.

m In Anti-Virus Mode, click the F-Secure Policy Manager
Console Status tab to view the list of products that were
installed.
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