Eng
  1. Skip to navigation
  2. Skip to content
  3. Skip to sidebar


Vulnerability protection

Microsoft Office vulnerabilities could allow remote code execution


Report ID: MS201205002
Date Published: 9 May 2012

Criticality: Important
Compromise Type: remote-code-execution
Compromise From: remote


Affected Product/Component:

Microsoft Office 2003
Microsoft Office 2007
Microsoft Office 2010
Microsoft Office 2008 for Mac
Microsoft Office for Mac 2011
Microsoft Excel Viewer
Microsoft Office Compatibility Pack




Summary

Multiple vulnerabilities reported in Microsoft Office could be exploited into allowing a remote attacker to execute arbitrary code on an affected system.



Detailed Description

Microsoft has released a security update to resolve multiple vulnerabilities that were found in Microsoft Office. Six vulnerabilities were reported, all were caused by the way that Microsoft Excel handles memory when opening a specially crafted Excel file. Upon successful exploit, the vulnerabilities could provide an opportunity to a remote attacker to execute code and take control of an affected system.

This issue has been resolved through the latest security update by fixing the way that data are validated when opening Excel files. Users are recommended to install this latest update to protect their system from potential exploit.



CVE Reference

CVE-2012-0141
CVE-2012-0142
CVE-2012-0143
CVE-2012-0184
CVE-2012-0185
CVE-2012-1847



Solution

Install the latest security patch for applicable system, available for download from (https://technet.microsoft.com/en-us/security/bulletin/ms12-030)



Security Advisories

For a list of known vulnerabilities affecting F-Secure products and the released fixes, please refer to the Security Advisories page.