Deu
  1. Skip to navigation
  2. Skip to content
  3. Skip to sidebar


Support News

Firefox 10 not yet supported by Internet Security 2012

Mozilla Firefox version 10 is not yet supported by F-Secure Internet Security 2012. A fix will be made available soon.

F-Secure is aware of the problem with the recent release of Firefox 10 and our latest version of Internet Security 2012. Our development team is already working on a resolution, which will be made available during next week. Meanwhile you can work around the issue by using other supported browsers. When the resolution is available, it will be automatically downloaded to your device, and no action will be required on your behalf. If you need any further information or updates regarding this issue, please check F-Secure Community.